Migration der PHP Version: Prüfung, wenn bereits PHP als CGI verwendet wird

Schritt 1:


Haben Sie die PHP Version nicht per .htaccess sondern im KAS (technische Verwaltung) festgelegt, können Sie direkt zu Schritt 4 dieser Anleitung gehen.

Schritt 2:

Migration der PHP Version - Prüfung, wenn bereits PHP als CGI verwendet wird, Bild 2

Um die .htaccess Datei zu bearbeiten, klicken Sie rechts auf das Symbol bearbeiten.

Schritt 3:

Migration der PHP Version - Prüfung, wenn bereits PHP als CGI verwendet wird, Bild 3

Notieren Sie sich die eingesetzte PHP Version und löschen Sie anschließend die AddHandler Zeile aus der .htaccess Datei heraus und speichern Sie.

Schritt 4:

Migration der PHP Version - Prüfung, wenn bereits PHP als CGI verwendet wird, Bild 4

Loggen Sie sich in dasKAS ein.

Klicken Sie links auf Domain und bearbeiten Sie Ihre verwendete Domain.

Schritt 5:

Migration der PHP Version - Prüfung, wenn bereits PHP als CGI verwendet wird, Bild 5

Wählen Sie nun eine höhere PHP Version aus. Verwenden Sie entweder die Version 5.5, 5.6 oder 7.0. Anschließend speichern Sie die Einstellung.

Schritt 6:

Migration der PHP Version - Prüfung, wenn bereits PHP als CGI verwendet wird, Bild 6

Rufen Sie nun Ihre Seite auf und prüfen Sie diese. Loggen Sie sich ggf. auch in den Administrationsbereich Ihrer Seite ein und prüfen Sie alle Funktionalitäten.

Sollten Sie eine Fehlermeldung erhalten, setzen Sie die PHP Version über das KAS (technische Verwaltung) wieder zurück. Wählen Sie diesmal die PHP Version aus, die Sie vorher aus der .htaccess gelöscht haben.
 
Wenn danach die Fehlermeldung nicht mehr erscheint, ist davon auszugehen, dass die Seite mit der neuen PHP Version nicht kompatibel ist.

In diesem Fall wenden Sie sich bitte an Ihren Webmaster oder an den Hersteller der verwendeten Software und prüfen Sie, ob es von der eingesetzten Version ein Update gibt. Generell sollten Sie Ihre Software aktuell halten. 
 
Wenn Sie ein CMS oder ein Blog-System verwenden, achten Sie bitte auch darauf, dass die eingesetzten Templates und Plugins / Erweiterungen ebenfalls auf den aktuellen Stand gehalten werden.
Suche
in Titel
in Beschreibung